Jump to content
  • 0

Connecting website to db


Guarder
 Share

Question

Hello, i've added this website:

 

but when i try to open it,it says

Spoiler

SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: NO)Access denied for user 'root'@'localhost' (using password: NO)

 

 

what should i edit?...i have this 3 files in config folder:

1.Connect.php

<?php
# IP DO DEDICADO
$ip = "79.137.33.234";
// Connect PHP PDO
$connect = 'mysql:host=localhost;dbname=l2jdb';

try {
	$db = new PDO($connect,'root','');
	$db->setattribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
} catch (PDOException $e) {
	echo $e->getMessage();
}

/*=======================================================================================*\
||########################| CONFIGURE NEWS |#########################||
\*=======================================================================================*/
$authorconf = 'Admin'; # Nome do author que irá aparecer nas news 


?>

2.Conf.php

<?php
$conexao = mysql_connect('localhost','root','') or die (mysql_error());
$banco = mysql_select_db('l2jdb', $conexao) or die(mysql_error());
$end = 'localhost';			 # Endere�o ou IP do seu site sem o 'http://www.', escreva assim: 'seusite.com.br' ou '200.145.221.89'
$nomedosite = 'L2 Forgot Life';

$host_smtp = 'mail.l2forgotlife.com';
$email_contato = 'EMAIL@l2forgotlife.com';
$senha_email_contato = 'SENHA';
?>

3.Config.php

<?php
$conexao = mysql_connect('localhost','root','') or die (mysql_error());
$banco = mysql_select_db('l2jdb', $conexao) or die(mysql_error());
$end = 'localhost';			 # Endere�o ou IP do seu site sem o 'http://www.', escreva assim: 'seusite.com.br' ou '200.145.221.89'
$nomedosite = 'L2 Forgot Life';

$host_smtp = 'mail.l2forgotlife.com';
$email_contato = 'EMAIL@l2forgotlife.com';
$senha_email_contato = 'SENHA';
?>

 

Edited by KIDutz
Link to comment
Share on other sites

Recommended Posts

  • 0

Google is your friend. :dat:

 

Hint, you have to edit some mysql properties. If server / website is on another host, you have to allow the connection. By default it restrict to local, from memory.

 

I know that crappy feeling configuring it for the first time. Enjoy the drive :happyforever:

  • Haha 1
Link to comment
Share on other sites

  • 0
2 hours ago, SweeTs said:

Google is your friend. :dat:

 

Hint, you have to edit some mysql properties. If server / website is on another host, you have to allow the connection. By default it restrict to local, from memory.

 

I know that crappy feeling configuring it for the first time. Enjoy the drive :happyforever:

 

privileges to the user in db are give, ports are opened.i just dont know how to set this configs.none of the tutorials i found doesnt look like this configs

Link to comment
Share on other sites

  • 0
Just now, KIDutz said:

 

no

so create new mysql account.

 

CREATE USER 'USER1'@'%' IDENTIFIED BY 'PASSWORD1';

and grant privileges for this user:

GRANT ALL ON *.* TO 'USER1'@'%';

'%' -  this mean for all ip address allow connect.

you can change it example to your website ip for security.

Link to comment
Share on other sites

  • 0
18 minutes ago, wongerlt said:

so create new mysql account.

 


CREATE USER 'USER1'@'%' IDENTIFIED BY 'PASSWORD1';

and grant privileges for this user:


GRANT ALL ON *.* TO 'USER1'@'%';

'%' -  this mean for all ip address allow connect.

you can change it example to your website ip for security.

 

SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not knownphp_network_getaddresses: getaddrinfo failed: Name or service not known

Link to comment
Share on other sites

  • 0
1 hour ago, KIDutz said:

it's still the same and nobody want to help me

 

are you retard or what?

  • Like 1
  • Haha 1
  • Upvote 1
Link to comment
Share on other sites

  • 0

you actually sound pretty retaded, you can't do any basic googling to solve own problems where EVERYTHING you try to do was explained in hundreds of ways already. If you expect someone to do it for you with 0 own effort, just pay for it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

AdBlock Extension Detected!

Our website is made possible by displaying online advertisements to our members.

Please disable AdBlock browser extension first, to be able to use our community.

I've Disabled AdBlock