Welcome to MaxCheaters.com

Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads

  • 0

Toma's C1 script compile problem


Go to solution Solved by MasterToma,

Question

any1 try to compile Toma's c1 script pack?its used by Qt creator+cmake IDE,i try to use it to compile his script but its always failed...

 

error message.

10:22:04: Running steps for project L2DataPack...
10:22:04: Starting: "C:\Program Files\CMake\bin\cmake.exe" --build . --target MultiSell
[1/1 1.0/sec] Running utility command for MultiSell
FAILED: script/MultiSell/CMakeFiles/MultiSell.util 
cmd.exe /C "cd /D C:\Users\sande\Downloads\build-l2datapack-DataPack-Release\script\MultiSell && "C:\Program Files\CMake\bin\cmake.exe" -E make_directory C:/Users/sande/Downloads/build-l2datapack-DataPack-Release/script_release/Script/ && cd /D C:\Users\sande\Downloads\build-l2datapack-DataPack-Release\script_release\Script && C:\Users\sande\Downloads\l2datapack\merge_files.py -e .msell --root_dir C:/Users/sande/Downloads/l2datapack/script/MultiSell --out_name C:/Users/sande/Downloads/build-l2datapack-DataPack-Release/script_release/Script/multisell.txt"
  File "C:\Users\sande\Downloads\l2datapack\merge_files.py", line 90
    print "%d '*%s' files were encoded and merged to %s" %(len(content_lines), args.extension, out_file_path)
                                                       ^
SyntaxError: invalid syntax
ninja: build stopped: subcommand failed.
10:22:06: The process "C:\Program Files\CMake\bin\cmake.exe" exited with code 1.
Error while building/deploying project L2DataPack (kit: DataPack)
When executing step "CMake Build"
10:22:06: Elapsed time: 00:02.

 

 

dw1222222.png

IDE configration used Toma's guide.

 

https://github.com/master-toma/l2datapack

 

 

maybe its merge_files.py problem?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
On 12/4/2020 at 11:21 AM, MasterToma said:

You need to use python 2.7, and looks like you are using python 3.+

marked as best answer

 

3 hours ago, sandeagle said:

rly thx Toma,finally,its worked.

locked.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.