Welcome to MaxCheaters.com

Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads

  • 0

Help L2AuthD 40504


Go to solution Solved by MasterToma,

Question

Recommended Posts

  • 0
8 hours ago, ShadowX256 said:

Windows 7 x64 Pro

SQL Server 2008

 

Created the OBDC files with C:\Windows\SysWOW64\odbcad32.exe

Capturar.PNG

you need to paste the whole errors either from the log or maximize the window and grab a bigger screenshot, cant see what the actual sql server is from that one

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Anarchy said:

you need to paste the whole errors either from the log or maximize the window and grab a bigger screenshot, cant see what the actual sql server is from that one

2

Just switched the Screenshot to a bigger one. And the L2AuthDError.txt is bloody empty.

 

1 hour ago, MasterToma said:

All possible startup SQL queries are failed. Probably this user doesn't have rights to the lin2db, or something else is wrong in DB settings

 

Where can I see the user's rights?

 

By the way, I tried to run it with SQL Express 2005, but the same errors happen.

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, ShadowX256 said:

Just switched the Screenshot to a bigger one. And the L2AuthDError.txt is bloody empty.

 

 

Where can I see the user's rights?

 

By the way, I tried to run it with SQL Express 2005, but the same errors happen.

looks like classic wrong default database, in the odbc dsn settings you'll want to set the default database to lin2db as shown below

 

Screenshot_10.png

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Anarchy said:

looks like classic wrong default database, in the odbc dsn settings you'll want to set the default database to lin2db as shown below

 

Screenshot_10.png

 

The AuthD returns "Invalid object name 'server' ", but once I run SELECT * FROM [dbo].[server] on Management Studio it works just fine.

 

About the dsn, I just checked it again and it seems okay to me. The dsn files are down below.

 

lin2clancomm.dsn

 

[ODBC]
DRIVER=SQL Server
UID=sa
DATABASE=lin2clancomm
WSID=STRIKEX
APP=Microsoft® Windows® Operating System
SERVER=STRIKEX\SQLEXPRESS
 

lin2comm.dsn

 

[ODBC]
DRIVER=SQL Server
UID=sa
DATABASE=lin2comm
WSID=STRIKEX
APP=Microsoft® Windows® Operating System
SERVER=STRIKEX\SQLEXPRESS

 

lin2db.dsn

 

[ODBC]
DRIVER=SQL Server
UID=sa
DATABASE=lin2db
WSID=STRIKEX
APP=Microsoft® Windows® Operating System
SERVER=STRIKEX\SQLEXPRESS
 

lin2log.dsn

 

[ODBC]
DRIVER=SQL Server
UID=sa
DATABASE=lin2log
WSID=STRIKEX
APP=Microsoft® Windows® Operating System
SERVER=STRIKEX\SQLEXPRESS
 

lin2report.dsn

 

[ODBC]
DRIVER=SQL Server
UID=sa
DATABASE=lin2report
WSID=STRIKEX
APP=Microsoft® Windows® Operating System
SERVER=STRIKEX\SQLEXPRESS
 

lin2user.dsn

 

[ODBC]
DRIVER=SQL Server
UID=sa
DATABASE=lin2user
WSID=STRIKEX
APP=Microsoft® Windows® Operating System
SERVER=STRIKEX\SQLEXPRESS
 

lin2world.dsn

 

[ODBC]
DRIVER=SQL Server
UID=sa
DATABASE=lin2world
WSID=STRIKEX
APP=Microsoft® Windows® Operating System
SERVER=STRIKEX\SQLEXPRESS
 

 

authD-3.PNG

Edited by ShadowX256
Couldn't see the text

Share this post


Link to post
Share on other sites
  • 0
59 minutes ago, Anarchy said:

yeah that's pretty funky it definitely looks correct, do you have multiple sql instances installed perhaps? it could be connecting to the wrong one

 

I don't think so, removed everything from the 2008 Installation before installing the 2005 Express one. Here is a screenshot of the Configuration Manager.

 

 

authD-4.PNG

Edited by ShadowX256

Share this post


Link to post
Share on other sites
  • 0
On 2/27/2019 at 4:42 PM, MasterToma said:

Try to remove everything under 


Software\\NCSoft\\L2AUTHD

And start again (remember, there might be few keys Software\\NCSoft\\L2AUTHD  in registry)

 

Yeah, I just tried that. It asks for the l2comm dsn file, but still doesn't work.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
26 minutes ago, MasterToma said:

Why does it ask for l2comm... Write lin2db after cleaning the registry.

 

Thanks a lot, it totally worked, you and Anarchy were very kind to help me with this. I wish luck for both of you.

Please mark the problem solved, SOLUTION: link to lin2db instead of lin2comm, no idea why it asks for L2Conn.

authD-5.PNG

Edited by ShadowX256
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
On 27/02/2019 at 16:42, MasterToma said:

Tente remover tudo em 


E comece novamente (lembre-se, pode haver poucas chaves  Software \\ NCSoft \\ L2AUTHD   no registro)

Hello, how are you?

 

What is the way to reach this record and delete them? I am unable to perform this task. Can someone help me?

 

 

I thank you in advance.

 

erro.jpg.51c71c477eed081704566592436b7b5a.jpg

Share this post


Link to post
Share on other sites
  • 0
55 minutes ago, looklin said:

Hello, how are you?

 

What is the way to reach this record and delete them? I am unable to perform this task. Can someone help me?

 

 

I thank you in advance.

 

erro.jpg.51c71c477eed081704566592436b7b5a.jpg


I don't think you've installed the databases properly...

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

This I managed to fix. Now I find the following error. Right after the server.exe closes.

 

err1.thumb.jpg.89f4369497b16169615dd097969df9fe.jpg

 

 

I get the following error in my LinError.txt

A:I:S:E:PE:DI:DE:BO=50.000000:4.000000:1.000000:25.000000:2.000000:0:0:0
L:Y:X:H=0:0:0:0:0
Crashed Thread[0].
CRASH
Server Up Time : Mon Apr 06 16:10:54 2020
Current Time : Mon Apr 06 16:11:26 2020
Elapsed Time : 0 days 0 hours 0 minutes 32 seconds
IOBufferPool - 19999 / 20000,  PendingWrite 10 bytes [0] 
=============== object report
user[0/0], npc[0/0], item[0/0], usersocket[0]
=============== npc server connection log 
no connect

[(568) 2020/04/06 16:11:26]: =======================
an Access Violation in module L2Server.exe at 0033:0054a6b8.
start at 2020/4/6 16:10:53
Write to location 00000000 caused an access violation.

Registers:
EAX=00000000 CS=0033 EIP=0054a6b8 EFLGS=00010246
EBX=00000000 SS=002b ESP=6d40fc20 EBP=0004c158
ECX=3f6ec8d0 DS=002b ESI=00400000 FS=0053
EDX=00000000 ES=002b EDI=00000000 GS=002b
Bytes at CS:EIP:
c6 03 01 65 48 8b 04 25 58 00 00 00 48 8b 0c f8 
Stack dump:
6d40fc20: 7850c084 00000000 0004c158 00000000 009d0560 00000000 00063244 00000000
6d40fc40: 7850c084 00000000 00002745 00000000 fffffffe ffffffff 00355480 00000000
6d40fc60: 0004c158 00000000 0061e5f9 00000000 7850c084 00000000 00400000 00000000
6d40fc80: 00000000 00000000 00063244 00000000 6d40fe50 00000000 00000000 00000000
6d40fca0: 407b4088 00000000 fffffffe ffffffff 00004000 00000000 00000000 00000000
6d40fcc0: 407b4088 00000000 1ca72b9c 00000000 7850c084 00000000 0000000b 00000000
6d40fce0: 7183e89c 00000000 7850c084 00000000 6d40fd58 00000000 7850c0d4 00000000
6d40fd00: 00000000 00000000 77d60780 00000000 00004000 00000000 407b4098 00000000
6d40fd20: 00670140 00000000 00000002 00000000 00000002 00000000 7183e89c 00000000
6d40fd40: 0000000b 00000000 1ca71fac 00000000 00000000 00000000 00000000 00000000
6d40fd60: 00000000 00000000 0000000b 00000000 3c900064 00000000 3c900044 00000000
6d40fd80: fffffffe ffffffff 77d6b910 00000000 00063234 00000000 016648d6 00000000
6d40fda0: 00000001 00000000 00000000 00000000 00400000 00000000 1ca732bd 00000000
6d40fdc0: 7183e89c 00000000 7850c084 00000000 00000000 00000000 00a05220 00000000
6d40fde0: fffffffe ffffffff 00400000 00000000 00977230 00000000 0062501b 00000000


ver = Dec 16 2005_22:03:13


GuardInfo : 

IOThread [0][16] (ahehe):  void IOThread_common(void *arglist) -> void CIOSocket::Close() -> void CDBSocket::OnClose() -> CacheSocket Closed
    Lock Stack  : 

IOThread [1][16] (good):  void IOThread_common(void *arglist)
    Lock Stack  : 

ListenThread [13][23480500] (good):  void ListenThread_common() -> void CJobFinishSignal::Init() -> bool CJobFinishSignal::WaitFinish(JobFinishType JobType, unsigned int nTimeOutSec)
    Lock Stack  : 

MainThread [12][16] (good):      Lock Stack  : 

GuardInfo end 



[(568) 2020/04/06 16:11:26]: *.\ioc.cpp:648(Tue Dec 13 02:52:40 2005) exception

I did a lot of research but I didn't find the solution.

I appreciate anyone who can help me.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.