Welcome to MaxCheaters.com

Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads

  • 0

Help Server At Virtualbox


Go to solution Solved by Zeeyo,

Question

11 answers to this question

Recommended Posts

  • 0
  • Solution

Make sure you have Bridged networking installed when installing VBox.

 

Then, select "Bridged adapter":

74f41Xt.png

 

This will make sure VBox is able to attain it's own IP address in the current host machine's subnet (instead of being behind an emulated NAT).

Adjust the IPv4 config of the guest OS as desired (if you have a LAN with a DHCP server, no further config).

 

 

 

EDIT: this method allows both local and remote connections. Default config (NAT) allows connections to services in the VM on localhost, if I recall it right…

Edited by Zeeyo

Share this post


Link to post
Share on other sites
  • 0

I have done this more do not know if are doing it right

very complicated

it is easier to win the lottery I hit the configuration

Anyone can make a small tutorial on how to do offline wheel

Edited by NaelsonMT

Share this post


Link to post
Share on other sites
  • 0

Have a look though this:

http://catlingmindswipe.blogspot.com/2012/06/how-to-virtualbox-networking-part-two.html

(Also read part 1!)

 

Also:

In your L2.ini you are telling the client to connect to 127.0.0.1.

This is the loopback address for the OS that's running the client. This isn't going to work.

You are running the L2Server inside a VM. Yes it's on the same physical hardware, but it's a different machine.

 

Like Zeeyo said, you should use a "Bridged" network adapter.

 

This means that the VM / OS that runs the L2Server is BRIDGED to your local network and is connected to it like any other computer or device you have.

 

A good way to test if you have it configured correctly:

On your real computer that runs the client:

Start > Run > Cmd: Type ipconfig and note your IP Address.

It's probably something like 192.168.1.XXX

 

If bridged networking is working for your L2 Server VM and you do the same thing, you should see a similar address when running the ipconfig command.

 

You might need to restart the VM when you make network changes.

 

I don't personally use VirtualBox but between what Zeeyo and i have posted you should be able to get it working.

 

*** Don't forget to disable or allow L2 though Windows Firewall ***

 

 

Share this post


Link to post
Share on other sites
  • 0

It only works if you have on a network?

my notbook I take to places where there is no internet  :okey:

I pulled the cord from the outlet wireless switch off and also serves  

cut connection to client

More anyway already help me a lot to get log just wanted to know if there is way without network cable or wireless

 

thanks tk422   Zeeyo  :D  :D

Edited by NaelsonMT

Share this post


Link to post
Share on other sites
  • 0

Yes. The problem is that you created C4 lin2db tables, even though you are using Prelude (used by clients 336-555) AuthD. If you ACTUALLY use a modded C4 client with injected prelude auth DLL, then you should use the old lin2db tables from Prelude/C1 or their extended versions (C2/C3).

 

If you have a normal C4 client without custom code injection, then you should use the C4 AuthD (60215) with C4 AuthGateD.

 

P.S. I know that you already found a C5 system, PATCHED to use prelude Auth and to ignore GG. IF this system is from the same source, then YES, you must delete lin2db and execute queries from prelude/C1 lin2db SQL script.

Edited by Zeeyo

Share this post


Link to post
Share on other sites
  • 0

Value friends

:D  :D

I do not know how I solved more and as you said I did a mixture of C4 files

but I believe the main error was the system protocol downloaded the system Run the l2 killer

jPwqdhS.png

Share this post


Link to post
Share on other sites
  • 0

Make sure you have Bridged networking installed when installing VBox.

 

Then, select "Bridged adapter":

74f41Xt.png

 

This will make sure VBox is able to attain it's own IP address in the current host machine's subnet (instead of being behind an emulated NAT).

Adjust the IPv4 config of the guest OS as desired (if you have a LAN with a DHCP server, no further config).

 

 

 

EDIT: this method allows both local and remote connections. Default config (NAT) allows connections to services in the VM on localhost, if I recall it right…

Hi Zeeyo,

Can you share C4 authgated, I also tried with c4 60215 but could not log in.

I can only login with AuthD 4xxxx

Edited by ginji

Share this post


Link to post
Share on other sites
  • 0

Hi Zeeyo,

Can you share C4 authgated, I also tried with c4 60215 but could not log in.

I can only login with AuthD 4xxxx

Well, from what I have seen (on C5), those AuthDs for C3, C4, C5, C6 require that you inject prelude auth code to client (either directly to L2.exe or Engine.dll, or just add an import to L2.exe and do that in DllMain, e.g. C5ex.dll). So if you use 40504 successfully on C3 557+, or any later chronicle, that means that you have a customized client system folder (in other words, it does not use the auth method it was using back in the day).

 

The sad thing about C4 AuthGateD is that it's simply useless today.

C4 and C5 clients have hardcoded checks for GG process all over their network code. If GG is not running, the client will not build any packets (and will not send any).

And the best part is, both C4 and C5 noGGs out in the public only disable modal GG dialogs in nwindow.dll. They do not remove the hardcoded checks. Which is most likely why you are using a custom system with prelude auth injected.

 

Now you might ask, why the hell can't we simply run a completely clean client on a legacy OS, for example Win XP x86, with a GG download server emulator to download old (C4/C5 dated) GG files (idk if anyone even has them).

The answer is that C4/C5 GG (Lineage2US.ini & other IDfiable content) is blacklisted @ nProtect. If you have no internet, you will always get a GG error, that's how it always was. But if you have internet, you will still get an error, as the game itself is blacklisted.

 

So unless someone has time and is willing to spend their effort on cleaning up GG from C4/C5 clients (or has already done so, and could share), all you will see is that with a clean client C4 AuthGateD sends a single packet and client does not respond. (e.g. it "doesn't" work). Not that the 40504/C4 works with a clean client either.

Edited by Zeeyo

Share this post


Link to post
Share on other sites
  • 0

Well, from what I have seen (on C5), those AuthDs for C3, C4, C5, C6 require that you inject prelude auth code to client (either directly to L2.exe or Engine.dll, or just add an import to L2.exe and do that in DllMain, e.g. C5ex.dll). So if you use 40504 successfully on C3 557+, or any later chronicle, that means that you have a customized client system folder (in other words, it does not use the auth method it was using back in the day).

 

The sad thing about C4 AuthGateD is that it's simply useless today.

C4 and C5 clients have hardcoded checks for GG process all over their network code. If GG is not running, the client will not build any packets (and will not send any).

And the best part is, both C4 and C5 noGGs out in the public only disable modal GG dialogs in nwindow.dll. They do not remove the hardcoded checks. Which is most likely why you are using a custom system with prelude auth injected.

 

Now you might ask, why the hell can't we simply run a completely clean client on a legacy OS, for example Win XP x86, with a GG download server emulator to download old (C4/C5 dated) GG files (idk if anyone even has them).

The answer is that C4/C5 GG (Lineage2US.ini & other IDfiable content) is blacklisted @ nProtect. If you have no internet, you will always get a GG error, that's how it always was. But if you have internet, you will still get an error, as the game itself is blacklisted.

 

So unless someone has time and is willing to spend their effort on cleaning up GG from C4/C5 clients (or has already done so, and could share), all you will see is that with a clean client C4 AuthGateD sends a single packet and client does not respond. (e.g. it "doesn't" work). Not that the 40504/C4 works with a clean client either.

Thanks, very clear!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.