Jump to content

lagunyve

Members
  • Content Count

    15
  • Joined

  • Last visited

  • Feedback

    0%

Community Reputation

0 Neutral

About lagunyve

  • Rank
    Vassal

Profile Information

  • Gender
    Male
  • Country
    French Polynesia

Recent Profile Visitors

61 profile views
  1. Thanks. Server is now using less RAM and we can see the improvements now. Thanks a lot @Tryskell I think you found what's wrong with my server.
  2. Got those errors in log sometimes: 1089.311: [GC (Allocation Failure) 1089.311: [ParNew: 104717K->2999K(113024K), 0.0197582 secs] 2901337K->2799709K(4780904K) icms_dc=0 , 0.0199058 secs] [Times: user=0.08 sys=0.00, real=0.02 secs] 1127.703: [GC (Allocation Failure) 1127.703: [ParNew: 103479K->2708K(113024K), 0.0223378 secs] 2900189K->2799667K(4780904K) icms_dc=0 , 0.0225367 secs] [Times: user=0.08 sys=0.00, real=0.02 secs] 1162.453: [GC (Allocation Failure) 1162.453: [ParNew: 103188K->2131K(113024K), 0.0185006 secs] 2900147K->2799203K(4780904K) icms_dc=0 , 0.0186580 secs] [Times: user=0.07 sys=0.00, real=0.02 secs] 1200.053: [GC (Allocation Failure) 1200.054: [ParNew: 102611K->2388K(113024K), 0.0365686 secs] 2899683K->2799570K(4780904K) icms_dc=0 , 0.0367199 secs] [Times: user=0.08 sys=0.00, real=0.04 secs] 1233.817: [GC (Allocation Failure) 1233.817: [ParNew: 102868K->4991K(113024K), 0.0199087 secs] 2900050K->2802285K(4780904K) icms_dc=0 , 0.0200518 secs] [Times: user=0.08 sys=0.00, real=0.02 secs] 1275.089: [GC (Allocation Failure) 1275.089: [ParNew: 105471K->5713K(113024K), 0.0228596 secs] 2902765K->2803131K(4780904K) icms_dc=0 , 0.0230125 secs] [Times: user=0.09 sys=0.00, real=0.02 secs] 1313.199: [GC (Allocation Failure) 1313.200: [ParNew: 106193K->5963K(113024K), 0.0240173 secs] 2903611K->2803489K(4780904K) icms_dc=0 , 0.0242119 secs] [Times: user=0.09 sys=0.00, real=0.03 secs]
  3. Okay the settings are done, now I must check in game too. Do you think those settings are good to add too ? -XX:+UseConcMarkSweepGC -XX:+AggressiveOpts -XX:+CMSParallelRemarkEnabled -XX:SurvivorRatio=8
  4. @TryskellThis is my java conf actually, so I need to add a GC on it ? I use linux bash: java -Xbootclasspath/p:./jsr167.jar -server -Dfile.encoding=UTF-8 -Duser.timezone="Pacific/Tahiti" -Xms20G -Xmx20G -cp ../libs/lameguard.jar:config:../libs/* com.lameguard.LameGuard l2f.gameserver.GameServer > log/stdout.log 2>&1
  5. What about the buffers ? How should I set it ?
  6. As I said, freezes are not happening everytime but it happens only when I enable geodata with the specified settings. As I don't really understand how those settings works, can someone tell me which options can influence performance ? Maybe pathfinding takes to much sometimes when all players in the map are moving, I don't know. If I can tweak the configuration so that pathfinding is not consuming a lot, maybe it would be better ?
  7. Is stasis geodata available for Hi5 ? Is it free ?
  8. Hello everyone, I'm using https://bitbucket.org/l2jgeo/l2j_geodata/src as GEODATA for my server on Hi5. But when geodata is enabled, players are encountering freeze sometimes for 4 seconds, my server specs is 24GB RAM and 4vcore with HDD. I've already put -xmx 20GB on my GS launch script. There is my geodata.ini configuration: # Dimension maps GeoFirstX = 11 GeoFirstY = 10 GeoLastX = 26 GeoLastY = 26 # Template file geodata GeoFilesPattern = (\\d{2}_\\d{2})\\.l2j # If True GEODATA AllowGeodata = True # Allow the player to fall from the horizontal wall if he clicks on the wall itself AllowFallFromWalls = True #Motion keyboard (arrows) AllowMoveWithKeyboard = False # Increase to Z for packages ClientZShift = 16 # Optimization of geodata in memory, saves about 150MB memory # Optimization should first need to generate a map of matches CompactGeoData = True # The minimum difference between the layers MinLayerHeight = 64 # The maximum height of the step for geodata MaxZDiff = 64 # Diagonal Search # It should be disabled only for debugging PathFindDiagonal = True #Smooths the way # # It should be disabled only for debugging PathClean = True # Strongly accelerates the search, the effect on the quality of unknown # 0 - off, 1 - is just the beginning, 2 - the beginning and the end of the road PathFindBoost = 2 # The maximum height of the step to find a way PathFindMaxZDiff = 32 # The maximum time allowed to spend on the search path (in nanoseconds) PathFindMaxTime = 100000000 # Configure the buffers to find a way, the number of x size of the map (in cages geodata) # Minimum 96, maximum - 512 PathFindBuffers = 8x96;8x128;8x160;8x192;8x256;4x288;4x320;2x384;1x512 Please can you tell me how can I optimize it so there won't be freeze in game ? Regards.
  9. How to optimize Geodatas ? I use https://bitbucket.org/l2jgeo/l2j_geodata but there are some freezes. Should I disable pathfinding diagonal ?
  10. Okay problem was with HWID restriction. Just commented the HWID line in vote and it's fixed. You can close thread.
  11. I think there's a problem with HWID condition. Can you help me to bypass HWID and check only char and IP ? Please.
  12. This is the code I have: https://pastecode.xyz/view/96c10b28
  13. Hello, I'm actually using L2Mythras Hi5 shared files. The problem I have is with actual vote system. Simple, when someone vote on topzone website on the server, it has to wait 12h to receive rewards again. The problem is, when someone receive 12h wait time, everyone in the server has the same delay event if they never used .vote command before. Do you know how to do ? I use default RewardVote.java code from L2Mythras. Thanks.
  14. Hello, I'm currently testing the L2Mythras PACK that can be found on Server/Files forum. I have a problem with events like TvT, CtF, and every other automated events in the pack. When the event is about to start, a message is appearing to the players, and when they click on "join", the server act as they are registered, but when the event starts, console say that: https://i.imgur.com/MYzCKO9.png Capture the flag cannot start because it doesn't have enough players. Actually I've set min players at 2 for every event and I'm trying with a friend so 2 different IPs. Still not working. Also on console when I start gameserver, it show that starting date for not working events: 01.01.1970 Does anyone have fixed this problem ?? Regards,
×