Jump to content
  • 0

Someone to compile something for me.. or help me with an error!


N1nj4Styl3
 Share

Question

Hello!

I tried to compile: ttp://svn.l2jserver.com/branches/L2_GameServer_T2.5

 

But I experienced the following error: BUILD FAILED

E:\workspace\L2J_Server\build.xml:120: Ant 1.8.2 is required. But your version is Apache Ant version 1.7.1 compiled on June 27 2008

 

Any help will be much appreciated,thanks.

 

Chronicle: Freya.

Link to comment
Share on other sites

Recommended Posts

  • 0

Eclipse SDK 4.2.2

 

weird because it should have that version of ant, my guess would be some kind of weird backward compatibility issue try to modify it in the build file to 1.8.3 because that version is installed in 4.2.2 eclipse

Link to comment
Share on other sites

  • 0

weird because it should have that version of ant, my guess would be some kind of weird backward compatibility issue try to modify it in the build file to 1.8.3 because that version is installed in 4.2.2 eclipse

 

Thanks for the fast reply,

are you able to compile it for me? Please.

Link to comment
Share on other sites

  • 0

No worries, you just gotta update your ant dude.

 

If you're using Windows:

 

Download binary's version of ant from here (direct link): http://www.apache.org/dist/ant/binaries/apache-ant-1.9.1-bin.zip

 

Extract it somewhere, then open Eclipse and go to Window > Preferences > Ant > Runtime and click Ant Home.

 

Then choose the "apache-ant-1.9.1" folder, NOT the apache-ant-1.9.1-bin (first one).

 

Let me know how it goes.

Link to comment
Share on other sites

  • 0

No worries, you just gotta update your ant dude.

 

If you're using Windows:

 

Download binary's version of ant from here (direct link): http://www.apache.org/dist/ant/binaries/apache-ant-1.9.1-bin.zip

 

Extract it somewhere, then open Eclipse and go to Window > Preferences > Ant > Runtime and click Ant Home.

 

Then choose the "apache-ant-1.9.1" folder, NOT the apache-ant-1.9.1-bin (first one).

 

Let me know how it goes.

 

thats the issue tho, hes eclipse have 1.8.3 so a newer version than required yet it doesnt work thats why i told him to modify the build.xml maybe its a backward compatibility issue which is if the case would be the same probably with other versions also :)

Link to comment
Share on other sites

  • 0

thats the issue tho, hes eclipse have 1.8.3 so a newer version than required yet it doesnt work thats why i told him to modify the build.xml maybe its a backward compatibility issue which is if the case would be the same probably with other versions also :)

Yeah, he should have the newer version of Ant so there is something wrong but I think that my suggestion may be of help.

 

Let's see how it goes.

Link to comment
Share on other sites

  • 0

Yeah, he should have the newer version of Ant so there is something wrong but I think that my suggestion may be of help.

 

Let's see how it goes.

 

yeah he should try both and see if any works :D

Link to comment
Share on other sites

  • 0

Good to hear.

 

Btw Intrepid, I may work on your idea.

 

Did you do anything yourself or?

 

no not yet i just have a HUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUGE todo list and thats a part of it :)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Posts

    • Hello everyone,   Does anyone know how to turn off "proxy'? I'm trying to connect on server and i get error in Login server:   ========================================================== Error in Login Server ========================================================== "[15:01:53]  INFO IP: 84.126.108.137 Login: test Assigned to Proxy: 127.0.0.1" ==========================================================   And in proxies.xml say something about .properties file, but i cant find that file.     ========================================================== proxies.xml ========================================================== <?xml version='1.0' encoding='utf-8'?> <!DOCTYPE list SYSTEM "proxies.dtd"> <!-- In order to make this file be in use, EnableProxies in server.properties MUST be set to true --> <!-- This list should contain GameServer IPs. IP of the GameServer will be chosen for Player during Server Selection, based on Mask of his IP --> <!-- For example, if IP of the player is 153.4.138.226, all of the masks below will be checked if IP matches range of mask --> <!-- Mask 0.0.0.0/3 covers IPs from 0.0.0.0 to 31.255.255.255. Mask 32.0.0.0/3 covers IPs from 32.0.0.0 to 63.255.255.255 and so on --> <!-- So if IP of the player matches below mask, value in "ip" will be given to him, to connect with GameServer --> <!-- If player IP will not match any mask, Error in LoginServer logs will be printed --> <list>     <level min="40" max="86" ip="127.0.0.1"/>     <minChatMessages party="3" clan="5" ip="127.0.0.1"/>     <minChatMessages shout="5" ip="127.0.0.1"/>     <minChatMessages all="15" trade="5" ip="127.0.0.1"/>     <minChatMessages pm="3" clan="5" ip="127.0.0.1"/>     <mask mask="0.0.0.0/4" ip="127.0.0.1"/>     <mask mask="16.0.0.0/4" ip="127.0.0.1"/>     <mask mask="32.0.0.0/4" ip="127.0.0.1"/>     <mask mask="48.0.0.0/4" ip="127.0.0.1"/>     <mask mask="64.0.0.0/4" ip="127.0.0.1"/>     <mask mask="80.0.0.0/4" ip="127.0.0.1"/>     <mask mask="96.0.0.0/4" ip="127.0.0.1"/>     <mask mask="112.0.0.0/4" ip="127.0.0.1"/>     <mask mask="128.0.0.0/4" ip="127.0.0.1"/>     <mask mask="144.0.0.0/4" ip="127.0.0.1"/>     <mask mask="160.0.0.0/4" ip="127.0.0.1"/>     <mask mask="176.0.0.0/4" ip="127.0.0.1"/>     <mask mask="192.0.0.0/4" ip="127.0.0.1"/>     <mask mask="208.0.0.0/4" ip="127.0.0.1"/>     <mask mask="224.0.0.0/4" ip="127.0.0.1"/> </list> ========================================================== ==========================================================   If anyone could help it would be great.  
    • @Celestinewasnt this guy banned for selling shared stuff? 😄
    • I know xD ... please clean the topic. It's okay!
    • link off    anyone can share it ?   thks
  • Topics

×
×
  • Create New...

AdBlock Extension Detected!

Our website is made possible by displaying online advertisements to our members.

Please disable AdBlock browser extension first, to be able to use our community.

I've Disbaled AdBlock