Jump to content

Help Can't see Japanese/Chinese text in my Interlude Client


XBZhan
 Share

Recommended Posts

Hi.

I'm am making/translating some dat files to Japanese for Interlude client. I would like to test these using my local L2J server until I have them complete and ready to share.

 

Currently I have a clean interlude client, with patched system. I can log into the server without a problem. Everything looks great.

Now I put j-dats and j-glys in system folder, change localization.ini to Japanese, put L2font-j.utx (from JP classic files) into systextures, and edit ttfontinfo.ini for appropriate font. Alas when I log into client I see nothing. Only small traces of English from the DAT can be seen (ALT - R, ALT - B from system menu).

gSvGy74K8n.png.11dda559fed8319348cedda69013fd50.png

 

https://imgur.com/a/moGKK2K (And here a picture of the login screen. )

 

So I thought maybe something was wrong with my client/dats. So I took files from another server I play on, which has a Chinese patch, and tried to using those files on my clean client to see if I could load Chinese version on my local server. Again, same problem, I can't see the text. I know many things are different between my client and theirs, this server I play on, but I can't seem to figure out why their client can load Chinese characters and mine cannot. I would just test my j-dats on their server if I could, but their launcher, even when started from l2.exe, won't start with any edited files.

 

I have spent a few days now looking at these two client folders. I have searched the internet high and low. I have looked at Russian language patcher, browsed Chinese forums for Chinese patchers, etc. just to try and learn what must be done to make a working language patch. Now I fear I am too stupid to figure this out on my own, though I will continue to look, I am asking for help if anyone knows what direction I must go to get this working. 

 

EDIT: After making a copy of the servers files and replacing server address with local IP I was able to connect to my server with their Chinese Language patch. Now I think problem lies in using UTX from classic JP client or JP localization on Interlude client. I renamed the Japanese files to large/small.cn-gly and l2font-cn.utx and I get error while loading client. Now I am getting editor to compare UTX files. Sorry if I am saying a bunch of stupid things. Me noob 🙂

 

EDIT2: SOooo
1. I got into the L2Front-cn.utx using l2decrypt/l2tool/UE2. https://imgur.com/a/gRPdZJX 
2. I tried to do the same for L2Font-J.utx taken from japanese classic files but when I open the decrypted file in UE I get an error https://imgur.com/a/CYmjX0C . I tried also to decrypt it using smart decrypt method as explained by Celestine on these forums but again, the program closed and I got this error message https://imgur.com/a/kqsmIuB . I tried both UE2 and UE3.

My only guess at this point is that the interlude client cannot read L2Font-j.utx taken from jclassic files, possibly do to differences in encryption. I wonder if there is anyway I can get into this L2Font-J.utx? If it is not possible (or too difficult for a noob such as myself), what is the best way to produce the dds files for small/large font so I can place them within the UTX files I am able to edit.

At this point I am pretty much taking shots in the dark, nevertheless I will keep trying. If anyone has any advice, it would be much appreciated. 

 

Edited by XBZhan
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

AdBlock Extension Detected!

Our website is made possible by displaying online advertisements to our members.

Please disable AdBlock browser extension first, to be able to use our community.

I've Disbaled AdBlock