Jump to content
  • 0

[Help]Problem with skills


Access
 Share

Question

iv got a few skills not working. and I cant find out where my problem is.

Take my rapis shot skill.

 

<skill id="99" levels="2" name="Rapid Shot" enchantLevels1="30" enchantLevels2="30">

 <table name="#enchantMagicLvl"> 76 76 76 77 77 77 78 78 78 79 79 79 80 80 80 81 81 81 82 82 82 82 83 83 83 84 84 85 85 85 </table>

 <enchant1 name="magicLvl" val="#enchantMagicLvl"/>

 <enchant2 name="magicLvl" val="#enchantMagicLvl"/>

 <table name="#ench1time"> 1240 1280 1320 1360 1400 1440 1480 1520 1560 1600 1640 1680 1720 1760 1800 1840 1880 1920 1960 2000 2040 2080 2120 2160 2200 2240 2280 2320 2360 2400 </table>

 <table name="#ench2MpConsume"> 20 20 19 19 19 18 18 18 17 17 17 16 16 16 15 15 15 14 14 14 13 13 12 12 12 11 11 11 10 10 </table>

 <table name="#ench2mpInitialConsume"> 5 5 5 5 5 5 5 5 5 5 4 4 4 4 4 4 4 4 4 4 3 3 3 3 3 3 3 3 3 3 </table>

 <table name="#mpConsume"> 10 20 </table>

 <table name="#mpInitialConsume"> 4 5 </table>

 <table name="#rate"> 1.08 1.12 </table>

 <table name="#aggro"> 303 549 </table>

 <set name="mpConsume" val="#mpConsume"/>

 <set name="mpInitialConsume" val="#mpInitialConsume"/>

 <set name="target" val="TARGET_SELF"/>

 <set name="reuseDelay" val="3000"/>

 <set name="hitTime" val="1500"/>

 <set name="skillType" val="BUFF"/>

 <set name="operateType" val="OP_ACTIVE"/>

 <set name="aggroPoints" val="#aggro"/>

 <enchant2 name="mpConsume" val="#ench2MpConsume"/>

 <enchant2 name="mpInitialConsume" val="#ench2mpInitialConsume"/>

 <for>

   <effect name="Buff" time="1200" val="0">

     <mul order="0x30" stat="pAtkSpd" val="#rate">

       <using kind="Bow"/>

     </mul>

   </effect>

 </for>

 <enchant1for>

   <effect name="Buff" time="#ench1time" val="0">

     <mul order="0x30" stat="pAtkSpd" val="1.12">

       <using kind="Bow"/>

     </mul>

   </effect>

 </enchant1for>

</skill>

 

 

 

 

Can we find anything wrong with this? its not giving the atk speed. its giving the buff, but dont add anything to stats.

Same for my Zealot. and a few others. Any help is appreciated.

 

Thanks

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

sorry dude can't find ur mistake but i can take my skill it work 100% u can find the mistake by ur self :D table is not taff pm me if u need help

and post please where was ur mistake (thy)

<skill id="99" levels="2" name="Rapid Shot" enchantLevels1="30" enchantLevels2="30" >

 <table name="#enchantMagicLvl"> 76 76 76 77 77 77 78 78 78 79 79 79 80 80 80 81 81 81 82 82 82 82 83 83 83 84 84 85 85 85 </table>

 <enchant1 name="magicLvl" val="#enchantMagicLvl"/>

 <enchant2 name="magicLvl" val="#enchantMagicLvl"/>

 <table name="#ench1time">

 1240 1280 1320 1360 1400 1440 1480 1520 1560 1600

 1640 1680 1720 1760 1800 1840 1880 1920 1960 2000

 2040 2080 2120 2160 2200 2240 2280 2320 2360 2400

 </table>

 <table name="#ench2MpConsume">

 20 20 19 19 19 18 18 18 17 17

 17 16 16 16 15 15 15 14 14 14

 13 13 12 12 12 11 11 11 10 10

 </table>

 <table name="#ench2MpConsume_Init">

 5 5 5 5 5 5 5 5 5 5

 4 4 4 4 4 4 4 4 4 4

 3 3 3 3 3 3 3 3 3 3

 </table>

 <table name="#mpConsume"> 10 20 </table>

 <table name="#mpConsume_Init"> 4 5 </table>

 <table name="#rate"> 1.08 1.12 </table>

 <table name="#aggro"> 303 549  </table>

 <set name="weaponsAllowed" val="32"/>

 <set name="mpConsume" val="#mpConsume"/>

 <set name="mpInitialConsume" val="#mpConsume_Init"/>

 <set name="power" val="0.0"/>

 <set name="target" val="TARGET_SELF"/>

 <set name="reuseDelay" val="10000"/>

 <set name="hitTime" val="1500"/>

 <set name="skillType" val="BUFF"/>

 <set name="operateType" val="OP_ACTIVE"/>

 <set name="castRange" val="-1"/>

 <set name="effectRange" val="-1"/>

 <set name="aggroPoints" val="#aggro"/>

 <enchant2 name="mpConsume" val="#ench2MpConsume"/>

 <enchant2 name="mpInitialConsume" val="#ench2MpConsume_Init"/>

 <for>

   <effect count="1" name="Buff" time="1200" val="0">

     <mul order="0x30" stat="pAtkSpd" val="#rate">

       <using kind="Bow"/>

     </mul>

   </effect>

 </for>

 <enchant1for>

   <effect count="1" name="Buff" time="#ench1time" val="0">

     <mul order="0x30" stat="pAtkSpd" val="1.12">

       <using kind="Bow"/>

     </mul>

   </effect>

 </enchant1for>

</skill>

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

AdBlock Extension Detected!

Our website is made possible by displaying online advertisements to our members.

Please disable AdBlock browser extension first, to be able to use our community.

I've Disabled AdBlock