Jump to content
  • 0

[Help] Fatal Error when loading custom armor


InfinityOwners
 Share

Question

Ok, now here's the error:

GRAVE: Error in file C:\Users\CARLOS\Desktop\IL\gameserver\data\stats\armor\25000-25099.xml
java.lang.IllegalStateException: No SQL data for Item ID: 25030 - name: Vesper Nature Leather Gloves
at com.l2jserver.gameserver.skills.DocumentItem.parseItem(DocumentItem.java:122)
at com.l2jserver.gameserver.skills.DocumentItem.parseDocument(DocumentItem.java:96)
at com.l2jserver.gameserver.skills.DocumentBase.parse(DocumentBase.java:89)
at com.l2jserver.gameserver.skills.SkillsEngine.loadData(SkillsEngine.java:154)
at com.l2jserver.gameserver.skills.SkillsEngine.loadArmors(SkillsEngine.java:113)
at com.l2jserver.gameserver.datatables.ItemTable.load(ItemTable.java:334)
at com.l2jserver.gameserver.datatables.ItemTable.<init>(ItemTable.java:224)
at com.l2jserver.gameserver.datatables.ItemTable.<init>(ItemTable.java:57)
at com.l2jserver.gameserver.datatables.ItemTable$SingletonHolder.<clinit>(ItemTable.java:994)
at com.l2jserver.gameserver.datatables.ItemTable.getInstance(ItemTable.java:204)
at com.l2jserver.gameserver.GameServer.<init>(GameServer.java:221)
at com.l2jserver.gameserver.GameServer.main(GameServer.java:490)
09-oct-2010 3:08:39 com.l2jserver.gameserver.skills.DocumentBase parse

 

Now, the thing is. SQL data DOES exist, and i made it on custom_armor and armor tables to be sure, but i still get the error.

Now, that error causes for NOTHING to load on the server, no weapons/armors. Mobs and rest are fine, but Buylists dont load because no items exist...Does anyone know how to fix this?

 

And another error referring to this is:

 

2010.10.09 03:08:39,613	SEVERE	10	com.l2jserver.gameserver.skills.DocumentBase	Error in file "gameserver\data\stats\armor\25000-25099.xml"

And nothing after that loads because it give that same error going on for armors/weapons.

 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

you need fix XML man, because some value are bad there, try compare it with another XML and fix that adding o removing some value.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

AdBlock Extension Detected!

Our website is made possible by displaying online advertisements to our members.

Please disable AdBlock browser extension first, to be able to use our community.

I've Disabled AdBlock