Jump to content
Sign in to follow this  
iiyama

Help gameserver doesn't read geodata(of this is what i understand) :D

Recommended Posts

Hello maxcheaters,aCis users,minions,protozoa!

So,i've got this problem that i cannot understand! Well,as you can see here1389880956_GeodataProblem2.thumb.png.cc91a84f123b3c09f417333b7bab7cbd.pngi've got the geodata files in potition.

 

 

My question now is,the configs are correct? 1397520013_GEODATAPROBLEM3.thumb.png.c3800d4a5d30242579fec5499d539d00.png

 

 

Just watch the gameserver... 351974109_Geodataproblem1.png.bd898fcb14bed34d41e953889bb599c3.png

 

Thanks for those who will help! :)

 

Share this post


Link to post
Share on other sites
20 minutes ago, iiyama said:

Hello maxcheaters,aCis users,minions,protozoa!

So,i've got this problem that i cannot understand! Well,as you can see here1389880956_GeodataProblem2.thumb.png.cc91a84f123b3c09f417333b7bab7cbd.pngi've got the geodata files in potition.

 

 

My question now is,the configs are correct? 1397520013_GEODATAPROBLEM3.thumb.png.c3800d4a5d30242579fec5499d539d00.png

 

 

Just watch the gameserver... 351974109_Geodataproblem1.png.bd898fcb14bed34d41e953889bb599c3.png

 

Thanks for those who will help! :)

 

geo added in loading list?

ged.png

  • Like 1

Share this post


Link to post
Share on other sites

My problem seems to be solved...I've got another issue now that i had before too...A character can fish inside town (not in water lel)but if i go near water it can't fish... What the heck??

Share this post


Link to post
Share on other sites

Don't touch the path line, keep it default as it reads automatically the 'root' location. Load of files is defined in bottom. Error is clear, you lack of ram. To fully load geodata you must assign 2G of ram for gameserver, that's means your pc must have at least 4G ram and it must be 64bit os. Otherwise, you have to deactivate some geodata files.

 

About fishing, there are some configs for that, plus, if you deactivated geo region then.. Don't expect it to work correctly. 

Share this post


Link to post
Share on other sites
11 hours ago, SweeTs said:

Don't touch the path line, keep it default as it reads automatically the 'root' location. Load of files is defined in bottom. Error is clear, you lack of ram. To fully load geodata you must assign 2G of ram for gameserver, that's means your pc must have at least 4G ram and it must be 64bit os. Otherwise, you have to deactivate some geodata files.

 

About fishing, there are some configs for that, plus, if you deactivated geo region then.. Don't expect it to work correctly. 

First of all,thanks for the answer dude! For the ram issue i have no problem (32gb ram installed on pc) so i need to know how to configure it (to give more ram for gameserver) and 2nd i can't find that config for fishing...

Share this post


Link to post
Share on other sites
Posted (edited)
3 minutes ago, iiyama said:

First of all,thanks for the answer dude! For the ram issue i have no problem (32gb ram installed on pc) so i need to know how to configure it (to give more ram for gameserver) and 2nd i can't find that config for fishing...

Open your gameserver.bat

look for

java -Dfile.encoding=UTF8 -Xms1024m -Xmx1024m -cp ./lib

and increase the 1024 value. (1GB). 2048 (2GB), 4096 (4GB) etc etc

Edited by HyperBlown

Share this post


Link to post
Share on other sites
3 minutes ago, HyperBlown said:

Open your gameserver.bat

look for

java -Dfile.encoding=UTF8 -Xms1024m -Xmx1024m -cp ./lib

and increase the 1024 value. (1GB). 2048 (2GB), 4096 (4GB) etc etc

you mean this? startgh.png.32e93325ccf865a74ab7cd3e84196d35.png

 

 

or on eclipse?

Share this post


Link to post
Share on other sites
Just now, iiyama said:

you mean this? startgh.png.32e93325ccf865a74ab7cd3e84196d35.png

 

 

or on eclipse?

Ye sthat. -Xmx1G = 1GB. increase to the amount you want to give to your gameserver

Share this post


Link to post
Share on other sites
2 minutes ago, SweeTs said:

Set it to 2G and you will be fine.

I gave it 3G just to be sure and it worked,right now i have this fishing issue...it can fish inside coliseum for example...

Share this post


Link to post
Share on other sites
26 minutes ago, iiyama said:

I gave it 3G just to be sure and it worked,right now i have this fishing issue...it can fish inside coliseum for example...

Hint: Open all your config files on notepad++, and do a global search for "fish" or something related to it. and examine the found lines.

Share this post


Link to post
Share on other sites

Yea, now I checked configs. There is no (anymore?) fish related config. There is only AllowWater. I don't remember exactly, maybe in past there was such a config. Make sure your geo is on and AlloWater (and such) are enabled.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×